User Password Reset Functionality Unavailable
Incident Report for New Relic
Resolved
The issue affecting password resets has now been resolved.
Posted 7 months ago. Jan 16, 2019 - 02:32 UTC
Investigating
Some customers may be experiencing an issue with password reset functionality. Please continue to monitor this page for updates.
Posted 7 months ago. Jan 15, 2019 - 23:32 UTC