All systems are working normally
Region: See status by region.
New Relic platform
Status of New Relic products and features
  • Operational
  • Partial outage
  • Major outage
  • Maintenance
Region: See status by region.
Incident History
November 2019 to January 2020

Subscription preferences

You’re almost done. Select the region, products, and services you use to receive the notifications that matter most to your business.

Warning! You are not subscribed to notifications until you complete the process by submitting your selections on this page.

 

Region

Receive notifications for the region in
which your account is based (US/EU).

 

New Relic One UI not accesible in the EU due to a CDN outage

Incident Report for New Relic

Monitoring

We have put in place mitigations for an issue with a Cloud Provider which has been causing UI issues for customers in the EU region. We will continue to monitor the situation while our Cloud Provider is working on a fix. If you continue to experience issues and are unable to access In-App support, please reach out to our Support team through this form: https:support.newrelic.comscontact-new-relic-support-form.
Posted Nov 18, 2025 - 15:23 UTC

Identified

We have engaged our cloud provider to assist with further investigation and are evaluating additional mitigation efforts. Some customers in the EU region may continue experience difficulty with the New Relic UI. If you are experiencing issues and unable to access In-App support, please reach out to our Support team through this form: https:support.newrelic.comscontact-new-relic-support-form.
Posted Nov 18, 2025 - 14:15 UTC

Investigating

Some customers in the EU region may experience difficulty logging into New Relic accounts. If you are experiencing issues and unable to access In-App support, please reach out to our Support team through this form: https:support.newrelic.comscontact-new-relic-support-form.
Posted Nov 18, 2025 - 12:34 UTC