Between 20:30:20 UTC on December 18th and 01:57:55 UTC on December 19th, some customers in the US region may have experienced false alerts and false loss of signal alert notifications. We have investigated and resolved this service interruption and impacted services have returned to normal operations.
Posted Dec 19, 2025 - 02:21 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 19, 2025 - 01:56 UTC
Update
We are continuing to investigate this issue.
Posted Dec 19, 2025 - 01:00 UTC
Update
We are continuing to investigate this issue.
Posted Dec 19, 2025 - 00:23 UTC
Update
Some customers in the US and EU region may experience false loss of signal alert notifications.
Posted Dec 18, 2025 - 23:52 UTC
Investigating
We are investigating a potential service interruption that may impact some customers. Please continue to monitor this page for updates.
Posted Dec 18, 2025 - 23:30 UTC
This incident affected: Alert Notifications : US (Infrastructure : US) and Alert Notifications : Europe (Infrastructure : Europe).