Subscribe to updates
All systems are working normally
Region: See status by region.
New Relic platform
Status of New Relic products and features
Cloud integrations
Status of cloud integrations
  • Operational
  • Partial outage
  • Major outage
  • Maintenance
Region: See status by region.
Incident History
November 2019 to January 2020

Subscription preferences

You’re almost done. Select the region, products, and services you use to receive the notifications that matter most to your business.

Warning! You are not subscribed to notifications until you complete the process by submitting your selections on this page.

 

Region

Receive notifications for the region in
which your account is based (US/EU).

 

Explorers Hub Unavailable
Incident Report for New Relic
Resolved
Between 02:00 UTC March 3rd and 17:59 UTC March 4th, some customers may have experienced error messages when logging into the Explorers Hub. We’ve resolved the issue with the Explorers Hub. Services have returned to their normal operation.
Posted Mar 04, 2021 - 10:28 PST
Investigating
Some customers are experiencing an issue accessing the Explorers Hub. We will update this page as we resolve the issue.
Posted Mar 04, 2021 - 09:53 PST
This incident affected: SUPPORT : Europe (Explorers Hub : Europe) and SUPPORT : US (Explorers Hub : US).