We resolved this service interruption and impacted services have returned to normal operation. Between 00:11 UTC and 02:45 UTC on March 3rd, 2026, some customers may have experienced delayed data in queries, charts, and dashboards as well as delayed or missing alert notifications for impacted data.
Posted Mar 03, 2026 - 02:59 UTC
Monitoring
We continue to see signs of recovery as we monitor impacted services. Some customers in the US region may be experiencing delayed data in queries, charts, and dashboards as well as delayed or missing alert notifications for related data. We will continue to provide updates until services return to normal operations.
Posted Mar 03, 2026 - 02:28 UTC
Update
We are still investigating the an issue where some customers in the US region may be experiencing delayed data in queries, charts, and dashboards as well as delayed or missing alert notifications for related data. We have been seeing signs of recovery, and will continue to provide updates until services are restored to normal operations.
Posted Mar 03, 2026 - 01:02 UTC
Update
We are continuing to investigate an issue where some customers in the US region may be experiencing delayed data in queries, charts, and dashboards as well as delayed or missing alert notifications for related data.
Posted Mar 03, 2026 - 00:36 UTC
Update
Some customers in the US and EU regions may be experiencing delayed data in queries, charts, and dashboards as well as delayed or missing alert notifications for related data.
Posted Mar 03, 2026 - 00:21 UTC
Investigating
Some customers in the US and EU regions may be experiencing delayed data in queries, charts, and dashboards as well as delayed or missing alert notifications for related data.